$re = '/(?<date>\S+)\s(?<time>\S+)\sp=(?<id>[\d]+)\su=(?<user>[\w]+)\s\|\s*TASK\s*\[(?<task>[^\]=]*)\s\w+=/m';
$str = '2019-03-24 17:57:14,202 p=19455 u=root | TASK [this is the task name msg=Debug message] ************************';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);