const regex = /(?<date>\S+)\s(?<time>\S+)\sp=(?<id>[\d]+)\su=(?<user>[\w]+)\s\|\s*TASK\s*\[(?<task>[^\]=]*)\s\w+=/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<date>\\S+)\\s(?<time>\\S+)\\sp=(?<id>[\\d]+)\\su=(?<user>[\\w]+)\\s\\|\\s*TASK\\s*\\[(?<task>[^\\]=]*)\\s\\w+=', 'gm')
const str = `2019-03-24 17:57:14,202 p=19455 u=root | TASK [this is the task name msg=Debug message] ************************`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}