#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(Release year: .+?)(; Platform: )(; Developer: )(; Publisher: )(; Country:)$"
Local $sString = "Release year: [SOME YEAR]; Platform: ; Developer: ; Publisher: ; Country:"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)