using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(Release year: .+?)(; Platform: )(; Developer: )(; Publisher: )(; Country:)$";
string substitution = @"$1";
string input = @"Release year: [SOME YEAR]; Platform: ; Developer: ; Publisher: ; Country:";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}