re = /^(Release year: .+?)(; Platform: )(; Developer: )(; Publisher: )(; Country:)$/m
str = 'Release year: [SOME YEAR]; Platform: ; Developer: ; Publisher: ; Country:'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result