const regex = /^(Release year: .+?)(; Platform: )(; Developer: )(; Publisher: )(; Country:)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(Release year: .+?)(; Platform: )(; Developer: )(; Publisher: )(; Country:)$', 'gm')
const str = `Release year: [SOME YEAR]; Platform: ; Developer: ; Publisher: ; Country:`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);