import re
regex = re.compile(r"^(Release year: .+?)(; Platform: )(; Developer: )(; Publisher: )(; Country:)$", flags=re.MULTILINE)
test_str = "Release year: [SOME YEAR]; Platform: ; Developer: ; Publisher: ; Country:"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)