$re = '/^(Release year: .+?)(; Platform: )(; Developer: )(; Publisher: )(; Country:)$/m';
$str = 'Release year: [SOME YEAR]; Platform: ; Developer: ; Publisher: ; Country:';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;