using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^N_([A-Za-z]+)-([A-Za-z]+)-([A-Za-z0-9]*)-([A-Za-z0-9_-éÉ\s]+)---";
string input = @"N_aa-AAAA-140143-AAAAAA_1---
N_AA-AA--AAAA_1---";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}