package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^N_([A-Za-z]+)-([A-Za-z]+)-([A-Za-z0-9]*)-([A-Za-z0-9_-éÉ\s]+)---`)
var str = `N_aa-AAAA-140143-AAAAAA_1---
N_AA-AA--AAAA_1---`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}