// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^N_([A-Za-z]+)-([A-Za-z]+)-([A-Za-z0-9]*)-([A-Za-z0-9_-éÉ\s]+)---").unwrap();
let string = "N_aa-AAAA-140143-AAAAAA_1---
N_AA-AA--AAAA_1---";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}