import re
regex = re.compile(r"^N_([A-Za-z]+)-([A-Za-z]+)-([A-Za-z0-9]*)-([A-Za-z0-9_-éÉ\s]+)---", flags=re.MULTILINE)
test_str = ("N_aa-AAAA-140143-AAAAAA_1---\n"
"N_AA-AA--AAAA_1---")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")