#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<plugin>[^\[\]]*)(\[(?P<version>[0-9.]*)\])?$"
Local $sString = "contactform[1.1]" & @CRLF & _
"limit_login_attempts[0.5]" & @CRLF & _
"maintenance_mode[1.0]" & @CRLF & _
"blog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")