import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<plugin>[^\\[\\]]*)(\\[(?P<version>[0-9.]*)\\])?$";
final String string = "contactform[1.1]\n"
+ "limit_login_attempts[0.5]\n"
+ "maintenance_mode[1.0]\n"
+ "blog";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}