$re = '/^(?P<plugin>[^\[\]]*)(\[(?P<version>[0-9.]*)\])?$/m';
$str = 'contactform[1.1]
limit_login_attempts[0.5]
maintenance_mode[1.0]
blog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);