re = /^(?P<plugin>[^\[\]]*)(\[(?P<version>[0-9.]*)\])?$/m
str = 'contactform[1.1]
limit_login_attempts[0.5]
maintenance_mode[1.0]
blog'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end