using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<plugin>[^\[\]]*)(\[(?P<version>[0-9.]*)\])?$";
string input = @"contactform[1.1]
limit_login_attempts[0.5]
maintenance_mode[1.0]
blog";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}