// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<plugin>[^\[\]]*)(\[(?P<version>[0-9.]*)\])?$").unwrap();
let string = "contactform[1.1]
limit_login_attempts[0.5]
maintenance_mode[1.0]
blog";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}