#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[^\/=]+=.*"
Local $sString = "file_paths" & @CRLF & _
"my-file-path/wefw/wefw/wef/wfweof=wefonwe/wfewoi=weoif/" & @CRLF & _
"my-file-path/wefw/wef/ef=wefonwe/wfewoi=weoif/" & @CRLF & _
"my-file-path/wef/wfe/wefw/wef/ef=wefonwe/wfewoi=weoif/"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)