import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\/=]+=.*";
final String string = "file_paths\n"
+ "my-file-path/wefw/wefw/wef/wfweof=wefonwe/wfewoi=weoif/\n"
+ "my-file-path/wefw/wef/ef=wefonwe/wfewoi=weoif/\n"
+ "my-file-path/wef/wfe/wefw/wef/ef=wefonwe/wfewoi=weoif/";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}