import re
regex = re.compile(r"[^\/=]+=.*", flags=re.MULTILINE)
test_str = ("file_paths\n"
"my-file-path/wefw/wefw/wef/wfweof=wefonwe/wfewoi=weoif/\n"
"my-file-path/wefw/wef/ef=wefonwe/wfewoi=weoif/\n"
"my-file-path/wef/wfe/wefw/wef/ef=wefonwe/wfewoi=weoif/")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)