#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<field2>\w+)\\(?<field3>[^\/]+)$"
Local $sString = "sourcefield=/var/log/bash_history/localuser/DOMAIN\first.last.domain" & @CRLF & _
"sourcefield=/var/log/bash_history/DOMAIN\first.last.domain/DOMAIN\first.last.domain"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")