$re = '/(?<field2>\w+)\\\\(?<field3>[^\/]+)$/m';
$str = 'sourcefield=/var/log/bash_history/localuser/DOMAIN\\first.last.domain
sourcefield=/var/log/bash_history/DOMAIN\\first.last.domain/DOMAIN\\first.last.domain';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);