import re
regex = re.compile(r"(?<field2>\w+)\\(?<field3>[^\/]+)$", flags=re.MULTILINE)
test_str = ("sourcefield=/var/log/bash_history/localuser/DOMAIN\\first.last.domain\n"
"sourcefield=/var/log/bash_history/DOMAIN\\first.last.domain/DOMAIN\\first.last.domain")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")