import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<field2>\\w+)\\\\(?<field3>[^\\/]+)$";
final String string = "sourcefield=/var/log/bash_history/localuser/DOMAIN\\first.last.domain\n"
+ "sourcefield=/var/log/bash_history/DOMAIN\\first.last.domain/DOMAIN\\first.last.domain";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}