// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<field2>\w+)\\(?<field3>[^\/]+)$").unwrap();
let string = "sourcefield=/var/log/bash_history/localuser/DOMAIN\\first.last.domain
sourcefield=/var/log/bash_history/DOMAIN\\first.last.domain/DOMAIN\\first.last.domain";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}