#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^|[a-z][_-]|\s)man"
Local $sString = "man" & @CRLF & _
"spider-man" & @CRLF & _
"manpower" & @CRLF & _
"iron_man" & @CRLF & _
"woman" & @CRLF & _
"human" & @CRLF & _
"-man" & @CRLF & _
"lol man" & @CRLF & _
"spooder--man" & @CRLF & _
"bad man" & @CRLF & _
"here. man."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")