import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|[a-z][_-]|\\s)man";
final String string = "man\n"
+ "spider-man\n"
+ "manpower\n"
+ "iron_man\n"
+ "woman\n"
+ "human\n"
+ "-man\n"
+ "lol man\n"
+ "spooder--man\n"
+ "bad man\n"
+ "here. man.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}