$re = '/(?<=^|[a-z][_-]|\s)man/m';
$str = 'man
spider-man
manpower
iron_man
woman
human
-man
lol man
spooder--man
bad man
here. man.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);