using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|[a-z][_-]|\s)man";
string input = @"man
spider-man
manpower
iron_man
woman
human
-man
lol man
spooder--man
bad man
here. man.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}