const regex = /(?<=^|[a-z][_-]|\s)man/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|[a-z][_-]|\\s)man', 'gm')
const str = `man
spider-man
manpower
iron_man
woman
human
-man
lol man
spooder--man
bad man
here. man.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}