re = /(?<=^|[a-z][_-]|\s)man/m
str = 'man
spider-man
manpower
iron_man
woman
human
-man
lol man
spooder--man
bad man
here. man.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end