using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[ \t]*\w[^\/\n\;]*);?";
string substitution = @"$1;";
string input = @" //цвета ключевых пикселей, испульзуемых в поиске
Global PxAlpha = -GenRgb( 0,0,0,0 ) // 1
//16777215 argb=0,255,255,255 - тоже пустой
RuntimeError(""TSprite.LoadMe Error: Red dot not found. ""+file )
EndIf
EndIf ;
EndIf;//kkk
//---- иначе просто добавляем в список фреймов анимации
Else";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}