// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[ \t]*\w[^\/\n\;]*);?").unwrap();
let string = " //цвета ключевых пикселей, испульзуемых в поиске
Global PxAlpha = -GenRgb( 0,0,0,0 ) // 1
//16777215 argb=0,255,255,255 - тоже пустой
RuntimeError(\"TSprite.LoadMe Error: Red dot not found. \"+file )
EndIf
EndIf ;
EndIf;//kkk
//---- иначе просто добавляем в список фреймов анимации
Else";
let substitution = "$1;";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}