const regex = /(^[ \t]*\w[^\/\n\;]*);?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[ \\t]*\\w[^\\\/\\n\\;]*);?', 'gm')
const str = ` //цвета ключевых пикселей, испульзуемых в поиске
Global PxAlpha = -GenRgb( 0,0,0,0 ) // 1
//16777215 argb=0,255,255,255 - тоже пустой
RuntimeError("TSprite.LoadMe Error: Red dot not found. "+file )
EndIf
EndIf ;
EndIf;//kkk
//---- иначе просто добавляем в список фреймов анимации
Else`;
const subst = `$1;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);