using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bPlus\b(?![^>]*<\/h\d+>)";
string substitution = @"{{Provider_Link '$&', 33}}";
string input = @"<h4 class=""Somethingsomething"" id=""something"">Plus plan</h4>The <b>Plus</b> plan starts at $14 per person per month and comes with everything from Basic.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}