use strict;
my $str = '<h4 class="Somethingsomething" id="something">Plus plan</h4>The <b>Plus</b> plan starts at $14 per person per month and comes with everything from Basic.';
my $regex = qr/\bPlus\b(?![^>]*<\/h\d+>)/mp;
my $subst = '{{Provider_Link \'$&\', 33}}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";