const regex = /\bPlus\b(?![^>]*<\/h\d+>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bPlus\\b(?![^>]*<\\\/h\\d+>)', 'gm')
const str = `<h4 class="Somethingsomething" id="something">Plus plan</h4>The <b>Plus</b> plan starts at \$14 per person per month and comes with everything from Basic.`;
const subst = `{{Provider_Link '$&', 33}}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);