import Foundation
let pattern = #"\bPlus\b(?![^>]*<\/h\d+>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<h4 class="Somethingsomething" id="something">Plus plan</h4>The <b>Plus</b> plan starts at $14 per person per month and comes with everything from Basic."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{{Provider_Link '$&', 33}}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)