re = /\bPlus\b(?![^>]*<\/h\d+>)/m
str = '<h4 class="Somethingsomething" id="something">Plus plan</h4>The <b>Plus</b> plan starts at $14 per person per month and comes with everything from Basic.'
subst = '{{Provider_Link \'$&\', 33}}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result