$re = '/\bPlus\b(?![^>]*<\/h\d+>)/m';
$str = '<h4 class="Somethingsomething" id="something">Plus plan</h4>The <b>Plus</b> plan starts at $14 per person per month and comes with everything from Basic.';
$subst = "{{Provider_Link '$&', 33}}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;