# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)(\..*)/$1/gm;t' <<< "T2a_u-rev.webp
T2a_u-rev.avif
T2a_u-rev.gif
T2a_u-rev.png
T2a_u-rev.jpg
T2a_u-rev.jpeg"