use strict;
my $str = 'T2a_u-rev.webp
T2a_u-rev.avif
T2a_u-rev.gif
T2a_u-rev.png
T2a_u-rev.jpg
T2a_u-rev.jpeg';
my $regex = qr/(.*)(\..*)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";