re = /(.*)(\..*)/m
str = 'T2a_u-rev.webp
T2a_u-rev.avif
T2a_u-rev.gif
T2a_u-rev.png
T2a_u-rev.jpg
T2a_u-rev.jpeg'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result