import Foundation
let pattern = #"(.*)(\..*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
T2a_u-rev.webp
T2a_u-rev.avif
T2a_u-rev.gif
T2a_u-rev.png
T2a_u-rev.jpg
T2a_u-rev.jpeg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)