#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)(\..*)"
Local $sString = "T2a_u-rev.webp" & @CRLF & _
"T2a_u-rev.avif" & @CRLF & _
"T2a_u-rev.gif" & @CRLF & _
"T2a_u-rev.png" & @CRLF & _
"T2a_u-rev.jpg" & @CRLF & _
"T2a_u-rev.jpeg"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)