const regex = /(.*)(\..*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)(\\..*)', 'gm')
const str = `T2a_u-rev.webp
T2a_u-rev.avif
T2a_u-rev.gif
T2a_u-rev.png
T2a_u-rev.jpg
T2a_u-rev.jpeg`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);