import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@import (url\\(\\\"?)?(url\\()?(\\\")?(.*?)(?(1)\\\")+(?(2)\\))+(?(3)\\\");\n";
final String string = "@import url('https://meyerweb.com/eric/tools/css/reset/reset200802.css');\n";
final String subst = "$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}