const regex = /@import (url\(\"?)?(url\()?(\")?(.*?)(?(1)\")+(?(2)\))+(?(3)\");
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@import (url\\(\\"?)?(url\\()?(\\")?(.*?)(?(1)\\")+(?(2)\\))+(?(3)\\");
', 'gm')
const str = `@import url('https://meyerweb.com/eric/tools/css/reset/reset200802.css');
`;
const subst = `$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);