#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*TM_TASK)(?=.*TM_CHECKLIST).*"
Local $sString = "TM_TASK TM_CHECKLIST is present" & @CRLF & _
"is only TM_TASK is present don't match" & @CRLF & _
"is only TM_CHECKLIST is present don't match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")